Piston Honda MKII - What is my current firmware?

Cwejman, Livewire, TipTop Audio, Doepfer etc... Get your euro on!

Moderators: Kent, luketeaford, Joe.

User avatar
VanWonky
Common Wiggler
Posts: 70
Joined: Fri Nov 07, 2014 5:54 am
Location: Perth, Australia

Piston Honda MKII - What is my current firmware?

Post by VanWonky » Wed Jun 10, 2015 11:24 pm

Howdy - asked this in the Harvestman forum but no luck so posting here. Can anyone please tell me how to find what firmware version is on my PH MK11? I have searched heaps with no luck.
Cheers
Dave

User avatar
ignatius
Super Deluxe Wiggler
Posts: 15940
Joined: Tue Dec 23, 2008 4:03 pm
Location: oregon
Contact:

Post by ignatius » Thu Jun 11, 2015 1:37 am

i have the answer in my email history at the shop. i can search through it tomorrow when i get in.

if you bought it new recently.. like any time in the last 6+ months it's got the latest firmware on it. Scott sent me the details though so i'll post here tomorrow once i find it.

User avatar
VanWonky
Common Wiggler
Posts: 70
Joined: Fri Nov 07, 2014 5:54 am
Location: Perth, Australia

Post by VanWonky » Thu Jun 11, 2015 2:24 am

Awesome - thanks very much. It is a very elusive subject seemingly!
ignatius wrote:i have the answer in my email history at the shop. i can search through it tomorrow when i get in.

if you bought it new recently.. like any time in the last 6+ months it's got the latest firmware on it. Scott sent me the details though so i'll post here tomorrow once i find it.

User avatar
CF3
Super Deluxe Wiggler
Posts: 3017
Joined: Tue Oct 26, 2010 5:40 pm
Location: East Coast

Post by CF3 » Thu Jun 11, 2015 9:49 am

Watching this intently. I'd love to know how to find out the OS on my PH MKII also. Emailed Harvestman months ago and never got a reply.

User avatar
VanWonky
Common Wiggler
Posts: 70
Joined: Fri Nov 07, 2014 5:54 am
Location: Perth, Australia

Post by VanWonky » Thu Jun 18, 2015 11:40 pm

Bump. Don't mistake me for someone who gives up easily! Anybody? I will even take a completely wrong answer at the moment like - "On power-up, hold every button down till the display counts up to 999" :hmm:

Dogma
Super Deluxe Wiggler
Posts: 4244
Joined: Wed Aug 28, 2013 10:46 pm

Post by Dogma » Thu Jun 18, 2015 11:47 pm

what does this firmware do? Im thinking of replacing the e350 (the e370 HAS to drop soon)
look up!

User avatar
VanWonky
Common Wiggler
Posts: 70
Joined: Fri Nov 07, 2014 5:54 am
Location: Perth, Australia

Post by VanWonky » Fri Jun 19, 2015 10:01 pm

This from the FB page:-
"Scott Jaeger - The frequency/morph stability on the Piston is slightly improved. There will be another update in the future with further improvements.
February 18, 2014 at 10:35am · Like · 1

Scott Jaeger - Radek: Your HD is most likely updated. The easiest way to tell is to listen to the primary sinewave output while selecting different wavefolding options. All three selections should sound "mostly" clean with the knob at zero - there are only very small differences in amplitude in the latest version. In the old version, there was some distortion happening in some modes with the knob at zero."

I suppose just going ahead and updating using the latest firmware if this is not clear can't hurt - can it? :confused:
Dogma wrote:what does this firmware do? Im thinking of replacing the e350 (the e370 HAS to drop soon)

User avatar
ignatius
Super Deluxe Wiggler
Posts: 15940
Joined: Tue Dec 23, 2008 4:03 pm
Location: oregon
Contact:

Post by ignatius » Fri Jun 19, 2015 10:53 pm

damn. sorry. slipped my mind.

i'll send myself an email at the shop as a reminder.

User avatar
VanWonky
Common Wiggler
Posts: 70
Joined: Fri Nov 07, 2014 5:54 am
Location: Perth, Australia

Post by VanWonky » Sat Jun 20, 2015 3:53 am

No problems - thanks Ignatius.
ignatius wrote:damn. sorry. slipped my mind.

i'll send myself an email at the shop as a reminder.

User avatar
ignatius
Super Deluxe Wiggler
Posts: 15940
Joined: Tue Dec 23, 2008 4:03 pm
Location: oregon
Contact:

Post by ignatius » Sat Jun 20, 2015 1:27 pm

per email w/scott March 2014:

"You can tell by looking at how many sliders are lit when turning the synth on- old version lights up all 3, new one only does two."

User avatar
VanWonky
Common Wiggler
Posts: 70
Joined: Fri Nov 07, 2014 5:54 am
Location: Perth, Australia

Post by VanWonky » Sat Jun 20, 2015 11:43 pm

OK - well in that case I am up to date. Loving this module but I have plenty to explore yet with the sounds it produces. Thanks again.
ignatius wrote:per email w/scott March 2014:

"You can tell by looking at how many sliders are lit when turning the synth on- old version lights up all 3, new one only does two."

User avatar
krunkleKick
Common Wiggler
Posts: 132
Joined: Wed Jun 30, 2010 6:46 am
Location: UK

Post by krunkleKick » Sun Jun 21, 2015 6:11 pm

ignatius wrote:per email w/scott March 2014:

"You can tell by looking at how many sliders are lit when turning the synth on- old version lights up all 3, new one only does two."
What? Really? Does this happen on anyones PH MKII? I'm sure I updated mine and all three still light up.

david_r
Veteran Wiggler
Posts: 509
Joined: Fri Dec 12, 2014 12:23 am
Location: SF Bay Area

Post by david_r » Sun Jun 21, 2015 8:48 pm

krunkleKick wrote:
ignatius wrote:per email w/scott March 2014:

"You can tell by looking at how many sliders are lit when turning the synth on- old version lights up all 3, new one only does two."
What? Really? Does this happen on anyones PH MKII? I'm sure I updated mine and all three still light up.
Mine does this. No matter which sliders are active, after a power cycle, the first 2 sliders are active.

User avatar
krunkleKick
Common Wiggler
Posts: 132
Joined: Wed Jun 30, 2010 6:46 am
Location: UK

Post by krunkleKick » Mon Jun 22, 2015 5:27 am

I better update again then! Maybe I used the wrong firmware the first time. Cheers :)

User avatar
VanWonky
Common Wiggler
Posts: 70
Joined: Fri Nov 07, 2014 5:54 am
Location: Perth, Australia

Post by VanWonky » Mon Jun 22, 2015 6:21 am

It would be interesting to see if you notice the differences that the update are supposed to produce.
krunkleKick wrote:I better update again then! Maybe I used the wrong firmware the first time. Cheers :)

User avatar
krunkleKick
Common Wiggler
Posts: 132
Joined: Wed Jun 30, 2010 6:46 am
Location: UK

Post by krunkleKick » Mon Jun 22, 2015 2:33 pm

VanWonky wrote:It would be interesting to see if you notice the differences that the update are supposed to produce.
I'll report back on that. Last time I "updated" it I thought it sounded better afterwards, evidently that may have been placebo effect.

User avatar
krunkleKick
Common Wiggler
Posts: 132
Joined: Wed Jun 30, 2010 6:46 am
Location: UK

Post by krunkleKick » Mon Jun 22, 2015 3:03 pm

Updated again with the version from the Harvestman website (pistonmk2v11.hex) using my Pickit2 - All three sliders are still always lit when I turn it on.

Maybe it's not updating correctly then. When I load the hex file it gives a yellow warning that some headers are missing, but still appears to let me upload it to the PHMKII and gives a green success message when it finishes.

Strange.

Voggg
Wiggling with Experience
Posts: 397
Joined: Thu Jul 03, 2014 10:53 pm
Location: Washington DC

Post by Voggg » Mon Jun 22, 2015 6:40 pm

I bought mine new last fall & it lights up all three. Haven't tried updating as I dont have a pickit. I'm curious if people notice much of a difference.

david_r
Veteran Wiggler
Posts: 509
Joined: Fri Dec 12, 2014 12:23 am
Location: SF Bay Area

Post by david_r » Mon Jun 22, 2015 8:42 pm

For reference I purchased mine November 26, 2014 from Detroit Modular.

User avatar
VanWonky
Common Wiggler
Posts: 70
Joined: Fri Nov 07, 2014 5:54 am
Location: Perth, Australia

Post by VanWonky » Mon Jun 22, 2015 10:06 pm

Good news over here!


Latest update now available.
http://theharvestman.org/firmware.php

:guinness:

User avatar
VanWonky
Common Wiggler
Posts: 70
Joined: Fri Nov 07, 2014 5:54 am
Location: Perth, Australia

Post by VanWonky » Mon Jun 22, 2015 11:15 pm

Sorry - didn't see your post when I added my last one.

OK - that is weird indeed. I will try to update mine with the newest firmware just posted in the next couple of days (rack is in bits atm) and see what happens. Hmm.. no mention of which LEDs will confirm this latest update?
krunkleKick wrote:Updated again with the version from the Harvestman website (pistonmk2v11.hex) using my Pickit2 - All three sliders are still always lit when I turn it on.

Maybe it's not updating correctly then. When I load the hex file it gives a yellow warning that some headers are missing, but still appears to let me upload it to the PHMKII and gives a green success message when it finishes.

Strange.

User avatar
euxine
Wiggling with Experience
Posts: 456
Joined: Mon Dec 22, 2014 11:47 am
Contact:

Post by euxine » Tue Jun 23, 2015 8:13 am

Scott just released v2.0 Firmware for the PH Mk II.
http://theharvestman.org/firmware.php

User avatar
TechnoPrisoner
Common Wiggler
Posts: 152
Joined: Tue Oct 01, 2013 6:14 am

Post by TechnoPrisoner » Tue Jun 23, 2015 11:15 am

slightly off topic,but are these pickit2 and pickit3 any good ?
they look ok but the price is much much cheaper than buying from the US


http://www.ebay.de/itm/microcontrollers ... 3f4df57540


http://www.ebay.de/itm/PICKIT3-kit3-Mic ... 3aa9d01890

thanks.

User avatar
krunkleKick
Common Wiggler
Posts: 132
Joined: Wed Jun 30, 2010 6:46 am
Location: UK

Post by krunkleKick » Tue Jun 23, 2015 11:18 am

I have installled v2.0 of the firmware and indeed now only the first two sliders light up. I'll take that as a success.

It does appear to be morphing a bit smoother although I'll need to give it a proper test later when I get the chance.

User avatar
CF3
Super Deluxe Wiggler
Posts: 3017
Joined: Tue Oct 26, 2010 5:40 pm
Location: East Coast

Post by CF3 » Tue Jun 23, 2015 11:20 am

euxine wrote:Scott just released v2.0 Firmware for the PH Mk II.
http://theharvestman.org/firmware.php
Would love to upgrade mine. Sucks it takes a pickit programmer to do it :waah:

Post Reply

Return to “Eurorack Modules”