Any Yamaha CS owners/techs out there? ENV 3 not working

Any music gear discussions that don't fit into one of the other forums.

Moderators: Kent, luketeaford, Joe.

Post Reply
Jefro
Common Wiggler
Posts: 202
Joined: Fri Jun 02, 2017 7:02 pm
Location: Denver

Any Yamaha CS owners/techs out there? ENV 3 not working

Post by Jefro » Tue May 04, 2021 9:54 am

I just picked up a Yamaha CS-30 from overseas. After going over all of it’s features, I found a couple issues. First is that it needs to be recapped. No surprise there for a synth that seems to have been largely untouched internally since it left Yamaha in 1984.

I’ve also found ENV 3 to be non-functional, I assume that as a result of the bad capacitors, the VCA chip in the ENV circuit has been taken out of commission. Specifically, IC11 on the sequencer board. I’ve poked around with a multimeter which is how I came to this conclusion, but is there a specific test I can do to find out if the IG00151 is really the culprit? More importantly, can I perform this text without removing that chip from it’s home? I have some stuck screws that’s going to make removing that chip a real pain, which brings up my next question. Assuming the VCA chip is bad, I think I can delsoder it without worrying about those screws, but I’d have to replace it from the bottom side of the board. Physically, this isn’t an issue due to it’s sil configuration, but is there another reason why I shouldn’t try to do it this way?

Any help is appreciated for this bummed new CS-30 owner.
Last edited by Jefro on Wed May 05, 2021 8:17 am, edited 1 time in total.

skunk3
Common Wiggler
Posts: 201
Joined: Fri Apr 23, 2010 10:13 am
Location: USA

Re: Any Yamaha CS-30 owners/techs out there? ENV 3 not working

Post by skunk3 » Tue May 04, 2021 7:27 pm

I *wish* I was a CS-30 owner. :)
"vocoders are shameful in publics"

Jefro
Common Wiggler
Posts: 202
Joined: Fri Jun 02, 2017 7:02 pm
Location: Denver

Re: Any Yamaha CS-30 owners/techs out there? ENV 3 not working

Post by Jefro » Wed May 05, 2021 7:06 am

skunk3 wrote:
Tue May 04, 2021 7:27 pm
I *wish* I was a CS-30 owner. :)
It is a dream come true for sure to have my hands on such a cool old machine.

Jefro
Common Wiggler
Posts: 202
Joined: Fri Jun 02, 2017 7:02 pm
Location: Denver

Re: Any Yamaha CS owners/techs out there? CS-30 ENV 3 not working

Post by Jefro » Wed May 05, 2021 8:18 am

I somehow accidentally quoted my own post. I’m blaming my dog that jumped in my lap on top of my laptop

Jefro
Common Wiggler
Posts: 202
Joined: Fri Jun 02, 2017 7:02 pm
Location: Denver

Re: Any Yamaha CS owners/techs out there? ENV 3 not working

Post by Jefro » Thu May 06, 2021 10:20 am

I think I found a set of screw extractors that just might do the trick the remove the bracket over the envelope section of the sequencer PCB. I need the tiniest one ever to remove a screw about the size of an eyeglass screw.

I’m going to use this thread a bit as a blog. Sorry for that, but I think I should document what I’ve gone through to get this working for other CS owners in the future.

Post Reply

Return to “General Gear”